
Sounding Better!
HYPACK 2022 Release Notes

By Caroline Liu
This past year our programmers have been hard at work on some new HYPACK® 
products and programs, as well as upgrades to existing software and bug fixes. These 
release notes highlight what’s new in HYPACK® 2022.

HYPACK INTERFACE (SHELL)
• RAD/Beta Survey options are now removed from the Shell menu. Because 

development on RAD Survey is completed, RAD Survey replaces the previous Survey 
program and uses the same name.

• From the Project Items list, you can invert the Z-value in an individual XYZ file:
Right-click on the XYZ file and select Invert Depths. A Save File dialog appears where 
you can save the inverted depths using the same file name or create a new file with a new 
name. Selecting Cancel will temporarily display the inverted values until you disable and 
enable the file again, however it does not change the data.

• Single beam HS2x files now draw depths of 0 instead of ignoring them, which 
previously left gaps in the data.

• The Tide View graph displays multi-day tides.
• Georeferenced PDF files are drawn at an increased resolution of 300 DPI.
• KML file points are drawn in black.
• Target Database shows targets in the same order as the legacy Target Editor.
• ESRI Export: Corrected coding conditions which caused the Geodatabase window to fail.
• Updated files for interface localization are now available for Russian.
• Polish language interface is now available.
• Fixed an error caused by parentheses in text entries that occurred when drawing 

DG2 charts.
• Instant Matrix Profile honors Elevation Mode.
• Removed HYSWEEP Cube from the Shell menu.
• Remote Assistance (Team Viewer) option is removed from the Help menu in Shell if 

it is not installed. For the HYPACK 2022 setup, installing Remote_Assistance.exe 
(Team Viewer) is optional.

• Added HYPACK Absolute rounding style in HYPACK Shell and coRtl. To use, go to 
Settings > Settings > Soundings tab and select from the Rounding drop down menu. It is 
similar to the HYPACK rounding style, but rounds against the absolute value of the 
sounding. For example:
> 40.25 rounds to 40.3
> -40.25 rounds to -40.3
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> 40.55 rounds to 40.6
> -40.55 rounds to -40.6

SOFT LICENSES
A soft license, which uses web-based license activation and deactivation routines, is now 
available as a replacement option for the HYPACK key (dongle). Soft licenses are compatible 
with dongles, which means you can pair a HYPACK® Max soft license with a dongle and 
continue to have full functionality. Note that there are activation routines in place for 
HYPACK® computers with or without an Internet connection. 
IMPORTANT: The soft license must be refreshed at least once every 90 days. If the license 

is not refreshed within this time frame, it will be deactivated. Each time you 
refresh your license, the 90-day offline countdown timer restarts.

The license refreshes automatically when you launch HYPACK® on a computer while 
connected to the Internet. If your HYPACK® computer has no Internet access, refreshing 
your license will require a second online device that has data transfer capabilities with your 
HYPACK® computer.

NOTE: HYPACK® displays a reminder beginning 10 days before the end of your 90-day 
offline limit. The License Manager also displays the day count in the status bar.

Soft License Advantages
• Does not use a dongle, which can be damaged or lost.
• Easily transfer the license between computers, even if they are in different locations.
• Quick activation process from purchase to installation.

Soft License Disadvantages
• ARCS and S63 chart permits are not supported. You must continue using the dongle to 

use these permits.
• You cannot convert a leased soft license to a permanent license.

Bug Fix:

• Users can now activate their soft license normally in Spanish-language Windows®.

NEW HYPACK® PRODUCTS
We are releasing three new HYPACK products for 2022, two of which replace several 
existing software packages.

HYPACK® ECHO

The HYPACK® ECHO is our basic and affordable single beam software package designed 
for bathymetric surveying applications. This product replaces the Ultralite package. Any 
customers on the maintenance plan that has an Ultralite license will be converted to the Echo 
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license upon renewal. Echogram is supported and SBMAX64 is included, allowing customers 
to contour and sort within the HYPACK Single Beam Editor.

HYPACK® GEOPHYSICS

The HYPACK® Geophysics product is a new software package that encompasses the tools 
needed for a typical Geophysical survey. This product replaces the Marine Search, Acoustic 
and Sub-Bottom packages. Any customers on the maintenance plan that has one of these 
licenses will be converted to the Geophysics license.

HYPACK WATER QUALITY MAPPING

The Water Quality Mapping product is new for 2022, and has the ability to collect and 
process sensor data from various water quality sensors and ADCPs. The Water Quality 
Mapping software includes data collection and processing as well as HYPLOT and 
contouring. Access to HYPACK Water Quality Mapping package requires a separate license.

NEW MENU ITEMS
• Added the Environmental Editor to the Processing menu.

The Environmental Editor is a modification of the Magnetometer Editor, separating the 
features that allow you to view and edit data recorded to raw SMI records.

• Added OBJ Editor to the Preparation > Editors menu. 
The OBJ Editor enables you to modify OBJ files so they conform to HYPACK orientation 
conventions, are sized appropriately for your survey vessel, and optimized for the OBJ 
shape display in HARDWARE and Real Time Cloud (RTC).

• Added HYPLOT MAX to the Final Products menu.
HYPLOT MAX replaces HYPLOT Multi. You can add multiple maps and *.plt files to one 
sheet, insert various symbols and text boxes, create and add title blocks, and print or 
export the sheet as a PDF or TIFF.

• RAD Survey is removed.
Development has been completed for RAD Survey, aka our Beta Survey program. It now 
replaces Survey under the same name. Old survey has been renamed ClassicSurvey.exe 
and is included in the HYPACK 2022 folder.
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MATRIX INSTANT PROFILE
Sample Matrix Instant Profile

• Save icon > XYZ File stores a 
user-defined number of points 
and depths. 
The Samples option defines the 
number of points generated across 
the next profile line. You can export 
these points with the corresponding 
depths. The default number of 
points is 250, and the minimum is 
2.

NOTE: If the profile line crosses 
unfilled matrix cells the cor-
responding points are discarded, resulting in fewer points than specified in your 
output file.

• Instant Profile line generates points along the enabled channel template (*.CHN). 
Tip: To compare bottom and channel depths, click [Color] to remove the color fill.

Instant Profile of Bottom Depths with Channel Template Depths

• Save > Image creates a PNG screen capture of the currently displayed matrix profile.
• The status bar now shows the depth for each Cursor Mode.

Annotation Mode now displays the bottom depth at the cursor position. Default Mode still 
shows the depth at the cursor position.

SOUNDING COLORS
Bug Fixes
• Zone Fixes:
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> The Color Zones area is always displayed on color tables with editable zone colors. 
Zone colors are not displayed if you select a style with fixed colors, for instance DXF 
Colors, DXF Spectrum, and Contrast.

> Inverting colors also inverts zones.
> Zones are stored in the corresponding color table file to synchronize the selected 

Style and band colors.
• Alternate color table assignments remain in project transfer. 

A color table assigned to a data file (different than the default project color table) is stored 
in a project relative format, where possible, to be included when you Transfer the project.

• Color tables refresh when a launched process closes to pick up any changes.
• Most ancillary program modules automatically use the default project colors set in 

the HYPACK® Shell. We’ve added new code that works behind the scenes to keep your 
project colors consistent. 

NOTE: Do not name your color tables “color.hcf” or “colorint.hcf” because these file 
names are still used for other purposes.

• Live Preview: Click on different color tables in the Select Color Table window to 
automatically apply the colors to your data in the Shell display. Click [OK] to set the color 
table.

• In the Color Table Editor, the [Apply] button updates the color table in the HYPACK® 
Shell display.

CUSTOM SOUNDING COLORS

Custom colors appear at the bottom of the Color dialog where you can select them to define 
a particular color for soundings.

Color Selection Dialog

If you have particular colors that you 
want to use for your soundings, select 
those colors from the Color dialog and 
click [Add to Custom Colors] > [OK] so 
they are available to define the 
sounding colors in the Color Table 
Editor. 
To store these custom colors from the 
current editing session in the HCF file, 
click [OK] from the Color Table Editor. 
These colors are available the next 
time you edit that color table.
To easily make the same custom 
colors available in other color tables, save the custom color set in an INI file from the Color 
Table Editor by selecting File > Save Custom Colors. To use the custom color set in a 
different color table, load the appropriate INI file by opening the other table’s Color Table 
Editor and selecting File > Load Custom Colors. The saved custom colors will appear in the 
Custom Colors area of the color selection dialog.
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The custom color INI files are stored by default in C:\HYPACK Store\Color Tables.

SAVING YOUR COLOR FILE

• New options to save and open files. The Select Color Table window lists color files 
(*.hcf) stored in the project and shared color tables stored in C:\HYPACK Store\Color 
Tables. The Color Table Editor menu now includes additional file save and open options 
for shared color tables, which automatically open the C:\HYPACK Store\ folder for 
efficient access of color tables that may be used in multiple projects.
> To save a new color table, click File > Save or File > Save (Shared) to store the file 

in the project folder or the C:\HYPACK Store\Color Table folder, respectively.
> To save an existing color table to the other file location, use File > Save As or File 

> Save As (Shared).
• Zones are now stored with each color table. The HCF file has always stored bands 

and colors, however zones were previously not stored. Because of this, the zone display 
was often out of sync with the color bars. Storing zone colors to the color table’s HCF file 
corrects this problem now.

• Custom Colors are now stored with each color table. The custom colors from the 
current editing session are stored in the HCF file, making them available the next time 
you edit that color table. You can change the custom colors from the Color dialog or by 
loading a different custom color set. See “Custom Sounding Colors”  for more information.

COLOR TABLE ASSIGNMENTS FOR SURVEY OR DREDGEPACK® MAPS

When using SURVEY or DREDGEPACK®, you have the option to use up to six Map windows 
to display different values acquired or computed from your logged data. For example, Matrix 
files have two depth fields that enable you to choose from several values for color-coding the 
matrix — primarily Survey depth, Dredge depth, or the difference between the channel 
template and either the Survey or Dredge depth. You can set the values used to color the 
matrix from Matrix > Display Options.

Matrix Display Options

NOTE: These settings do not 
change the values that are 
stored in the matrix. They are 
for display purposes only. 
You can change them at any 
time.

Since these values are likely to 
represent significantly different depths or distances, you may need to use different color 
tables to differentiate each set of values. By default, all Map windows in SURVEY or 
DREDGEPACK® use the default color table for their displays, however you can use the 
Survey Map Window buttons to define a different color table for each map. 
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Sounding Colors Panel—All Map Windows Use the Default Color Table (left), Map 1 and 2 Show Alternate Color 
Tables (right)

To set a different color table for a Map, navigate to the Sounding Colors panel, click the 
button corresponding to the Survey Map window you want to update, select the color table 
from the Select Color Table window, and click [OK]. The button corresponding to the survey 
map will update with the name of the selected HCF file.

Each button with an alternate color table assignment displays the HCF file name on the 
button. Maps that use the default color table will display only the map name on its 
corresponding button.

PREPARATION

CHARTS
• For S57 Charts, the Distance Marks display option increases the font size for river mile 

numbers. 

GEODESY
• A warning is now displayed if a component of the RTK correction method is unspecified.

VDATUM SIMPLIFIED

The VDatum Zone and Surface drop-downs now read file names from the HYPACK VDatum 
folder (C:\HYPACK 2021\datum\vdatum) instead of only offering VDatums from our hard-
coded database. 
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Advantages
• Allows non-standard names in VDatum Surface drop-down as long as the files are 

appropriate. 
• Eliminates the very large VDatum install folder from HYPACK. 

> You now can download only the VDatum files you need from the NOAA site, rather 
than a large folder that includes all VDatum files.

> Avoids potential IT restrictions regarding software installation.
> Instantly updates the options for new and updated VDatum files. We don’t need to 

synchronize our coding for each NOAA change, and users can download and 
immediately implement NOAA changes. Everybody wins!

GEODESY IN THE PROJECT WIZARD

The new Selection Mode options expand the available methods you can use to set your 
project geodesy.

NOTE: Both of the new options are available only for UTM grids.

• Location Mode displays fields where you can enter the latitude and longitude of your 
project area. Then, when you click [Set Grid and Zone], the wizard automatically selects 
UTM North or South based on the latitude, and the zone based on the longitude.
Location Mode

• Click on the Map displays a world map where you can use your cursor to indicate the 
location of your survey area. The wizard then chooses the UTM Grid and Zone 
accordingly. If you want to adjust your location using the map again, the Show Map link 
reopens the map display.
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Click On Map Mode

As before, the RTK Tide calculation method appears in the display but any changes must be 
made in the GEODETIC PARAMETERS module. Click the Advanced Settings link to get 
there.

GEODETIC PARAMETERS 
• Added geoid model for France (RAF20.geo).
• Added option to select geodesy by entering ESPG codes.
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HYPACK HARDWARE

SUPPORT FOR 3D OBJ BOAT SHAPES

In the Offsets tab, in addition to the default or *.3OD shape files, you can also now load 3D 
OBJ files to represent the mobile (Boat) and hardware devices. The display shows your 
devices, relative to the mobile with the offsets currently configured for each device.
The Transparent Vessel option enables you to see devices positioned within the mobile 
shape. (Otherwise, it would be hidden in the display.)

OBJ Shape in HARDWARE—Transparent (left), Opaque (right)
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• New Test Device button in Hardware for multibeam and side scan devices

• Double click on a device to pop up the setup window (for Survey, MB, and SS devices).

DRIVER UPDATES

• EchotracE20.dll: Added option to use the timetag from the device over HYPACK® 
SURVEY time.

• GPS.dll: PTNL,GGK msg. has been updated for the new Trimble status codes.

Updated PTNL,GGK Quality Indicators.

• MDL.dll: Converts input measurements to survey units.
• NOAATides.dll: Corrected problem reading NOAA tides on Windows® 7 computers.
• SBG.dll: Corrected problem with logging through midnight.
• Subbot.dll: Works in a playback configuration (as well as for data collection).

0: Fix not available or invalid
1: Autonomous GPS fix
2: RTK float solution
3: RTK fix solution
4: Differential, code phase only solution (DGPS)
5: SBAS solution – WAAS/EGNOS/MSAS
6: RTK float or RTK location 3D Network solution
7: RTK fixed 3D Network solution
8: RTK float or RTK location 2D in a Network solution
9: RTK fixed 2D Network solution
10. OmniSTAR HP/XP solution
11: OmniSTAR VBS solution
12: Location RTK solution
13: Beacon DGPS
14: CenterPoint RTX
15: xFill
16: INS Dead Reckoning
21.1.
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• Vulcan.dll: Updated to honor the Use Uncorrected Depths matrix option in SURVEY. 
Currently the driver takes whatever the setting is on startup. So, if you change it, you 
must restart SURVEY/DREDGEPACK®. 

• Advanced Nav INS driver: Corrected inverted heave. 
• DQM_Mechanical.dll: Norfolk The data can come over a choice of ethernet or a serial 

port. On this $RAW string only boom angle is applied to bucket depth math.
• Sample String: 

$RAW,craneroll,cranepitch,boomangle,bargeroll,bargepitch,barometer,draft,temp
• Echotrac E20 driver: Added support for 32-bit echogram. Any data logged with the E20 

is logged at full-quality—no downsampling as in earlier versions. 
• Both the 32-bit and 64-bit Single Beam Editors have also been updated to process this 

new, full-quality echogram data.

NOTE: SBMax 21.2.0 or SBMax64 21.2.2 and newer is required for processing.

The E20 Device window in SURVEY includes Signal Range buttons to adjust the display 
brightness. This does not affect the recorded data – you will always record the full 
resolution echogram data, regardless of your Signal Range setting.

NOTE: It’s likely that, with the increased echogram signal range, you’ll need to lower the 
signal range until you see your imagery.

Sample E20 Echogram Display

• Geodimeter Driver: 
> Added support for Trimble S6 Robotic Total Station
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> The vertical offset was subtracted instead of added, and it wasn't applied to the 39 
message.

> Fixed to work with 7,8,9 messages, when NavStation information is entered.
• Magnet.dll: 

> Changed the Marine Magnetics labels to be more clear. One is the compact format 
and the other is the standard format both of which are the same between the devices.

> Added support JW Fisher Proton 5, which has a separate message to include altitude.
> Corrected reading location
> Records the Device Specific Message in the Raw file.
> Outputs depth from Seaspy Horizontal Gratiometer for towfish.

• PosMV.dll: Fixed SURVEY crash if Tide is disabled.
• PosMV3000: The driver expected the sync string to begin with 0x99 0x90. Added support 

for sync strings beginning with 0x90 0x90.
• TideDr.dll:

> Recompile corrected problem when using the Hazen 3011 provision in the driver 
connected to a serial port.

> Does not report a new tide unless the value actually changes.
• Towfish.dll: 

> Added [Reset Towfish Position] to reposition the towfish at its maximum cable length 
directly behind the vessel until the driver receives device input data to calculate it.

> Added an LCI-90i option to the cable counter that reads this format correctly.
> In the device window, the layback only adjusts after you press [Enter].

• Add support for VectorNav INS.
• NOAA Online Tide Reader 

• Added tide offset. 
• Added a checkbox to use NOAA time.  The default is Veritime.
• NOAAWeather driver – fixed dead link
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• Generic Cutter DQM Parser - GenCutterDQM.dll - Initial version of GenCutterDQM. This 
is based on the original GenDevParse with a few additions.

HYSWEEP HARDWARE
• HYSWEEP_Extended.DLL Description corrected.
• Marine Sonic Seascan HDS: Removed Chinese characters in English device name.
• POS MV: Allows multiple instances.
• Reson, NORBIT, Kongsberg devices: Small changes to setup to avoid confusion.
• Multiple Frequency Drivers: Sonar frequency is HSX logged in RMB datagrams. 

Tacked on after ping number. HSX Format.doc changes are included in the ZIP. Most all 
of the HYSWEEP drivers have been updated to support this. Those that haven’t been 
updated and those that don’t know the frequency will log 0.

• Added an option to suppress logging WGS84 data to HSX files (FILE -LOGGING 
OPTIONS). 

• Added support for AML-3 and AML-6 (aka Orange Line probes).

Driver Modifications
• Advanced Nav INS driver: corrected inverted heave.
• Kongsberg Multiple Frequency Mode: Support Kongsberg KMALL datagrams.

> Supports datagrams that span multiple partitions. 2nd partition contains imagery data.
> Supports bathymetry in multiple frequency mode. The sample data used for debug 

contained 200, 300, 400 KHz data in interleaved pings. MBMAX64 breaks out 
soundings by frequency but MBMAX64 version 21.2.0 is required for Kongsberg 
multifrequency.
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> Supports GPS transfer to HYPACK® SURVEY driver, HYSWEEP_Extended.dll. This 
method should be considered beta until further testing.

• WASSUP driver: Extend slant range maximum from 650 m to 65,000 m.
• Warning if no altitude device installed.

• Updated Leica API, now supports all new (and old) Leica devices.
• VectorNav INS Support.
• Velodyne payload driver.

DATA ACQUISITION

SURVEY
A new version of SURVEY is now available in HYPACK 2022. In 2020, we released a beta 
version of SURVEY called RAD Survey. We have completed development of RAD Survey, 
which now replaces the old SURVEY program (aka Classic Survey). Classic Survey will 
be included in the install as ClassicSurvey.exe.
Some additions to RAD Survey from the past year that are now included in the new Survey 
release include:
• Added Query button to supplement existing menu item.
• Prevents multiple Comments windows.
• Select Target dialog now shows XY position of each target to distinguish between targets 

that could have the same name.
• Fixed Track Hazard Contours.
• Splash screen now updates copyright from the file information.
• Fixed missing code causing Resource 99 error.
• Added a “Use corrected depth” option for single beam AutoMatrix. Now you have the 

option to paint the AutoMatrix with corrected or uncorrected depths.
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• Added chainage Data Display options.

• Save XYZ file from matrix data.
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• New Device Health display that demonstrates the real time health status of drivers.

GRID DISPLAY SETTINGS

• Display updates when you click [Apply] or [OK].
• Lat/Lon label settings are saved correctly.
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DATA DISPLAY

• Enhanced settings consistent between sessions.
• Separators needed multiple fixes to work properly.

DREDGEPACK MODE

• In DREDGEPACK® mode, Reset Dredge option in the Edit Matrix dialog fixed.
• Fixed program failure caused by Zoom Extents when there are no background charts 

enabled.
>

REAL TIME CLOUD 
Display draws correctly when the legend is enabled.

DREDGEPACK

DRIVER UPDATES
• Inclinometer.dll now includes protocols for 2Gig Engineering and Telestra’s SignalQuest 

inclinometers.

SIDE SCAN SURVEY
• Klein 4900 reads depth correctly.
• When the Klein 4900 is assigned to a towfish, the side scan mosaic appears at the 

towfish location.
• Removed down sampling for improved waterfall display.
• Added arrows to target list box.
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• New water column display

• Support for EdgeTech 4205 has been added.
• The value of the low pass filter’s cutoff frequency can now be changed in the Analog 

Sidescan Monitor window.

HYSWEEP® SURVEY
• Sound Velocity Profile imports with centimeter resolution, not decimeter.
• R2Sonic Water Column displays: Fixed downsampling bug at ranges greater than 70m. 

Affected both Water Column Logger and Water Column Playback.
•  Oceanographic sound velocity probe: Added support for AML-3 and AML-6 (aka 

Orange Line probes). 
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> Operates the same as AML BASEX2. You will need to first add the device in 
Hardware:

Open Dialog in HYSWEEP® Survey, hit 'connect' then 'scan for files'. Select file you 
want and dialog pops with device. When using the device be sure the blinking green 
light turns solid to note it has GPS, otherwise depths will NOT be valid.

NOTE: Requires libssh2.dll in root HYPACK® folder.

SURVEY LOG
• Tools to manage multiple sets of header information:

> Export Header Data: Export the header information as a configuration file (*.ini) 
which will be saved in the project folder by default. You can choose to either overwrite 
an existing file or create a new configuration file.

> Import Header Data: Import the header information from a pre-existing configuration 
file (*.ini) to automatically repopulate the upper portion of the dialog.

• Option to restore survey data to the spreadsheet. Import Survey Log: You can 
import a raw Survey LOG (*.LOG) file or a CSV (*.csv) SURVEY LOG report file to restore 
survey information from a previous survey session to the spreadsheet area.

• Automatic log backup: SURVEY LOG automatically appends each log entry to 
survey_log.csv in the project folder. In case of system shutdown, you can restore the data 
from this file.

• Export as: Added support for a Comma Separated Values (*.CSV) format Survey Log 
Report (in addition to the existing PDF and Excel XLS formats).

• [Delete Row] removes the currently selected row in the survey log. It does not affect 
corresponding raw data files.

• Added Satellites and HDOP.
20



• Customize header names.

• Option to log targets to memo section

POST-PROCESSING

BOTH SINGLE BEAM EDITORS SUPPORT 32-BIT ECHOTRAC E20 
ECHOGRAMS

Both the 32-bit and 64-bit Single Beam Editors have been updated to process the full-quality, 
32-bit echogram data logged with the 21.2.x Echotrac E20 driver.
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E20 Echogram in 64-bit SINGLE BEAM EDITOR

NOTE: SBMax 21.2.0 or SBMax64 21.2.2 and newer is required for processing.

64-BIT SINGLE BEAM EDITOR (SBMAX64)
• The extension in the Open File dialog is now saved from the previous use. No more 

having to keep switching from *.LOG to *.*.
• Reads up to 2000 raw files. Formerly, it had a 256 file limit.
• In the Read Parameters, only HYPACK Navigation device appears as HYPACK 

Survey. Previously, a few other HYPACK devices also appearEd there as HYPACK 
Survey.

• Autoscale Z-range is more reliable. The program updates the depth range more often 
so autoscaling the colors to the depth range ignores deleted soundings.

• Arrows on the track line display to show heading 
during logging.
Sample Track Lines in the Survey Display

• Overlay displays corrected in the Survey and 
Profile displays.
Overlays Dialog:
> Single files loaded in the Overlays dialog 

now load properly. You can now mix single files 
and LOG files.

> The scrollbar loads consistently to enable 
viewing long file lists.

> Spreadsheet function improved:
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• Shifting groups of files: Select a group of files and click the up or down arrow 
buttons one or more times. The selected files all move together.

• Sort works better: You can load single files in a few cells and if you click sort the 
files will move to the proper row. 

NOTE: The sort function only works on the columns of the selected cells in the 
grid.

Profile Window:
> Overlay draws based on Show Depth 1 and 2 options.

• SBMAX64 reads 32-bit echograms as well as the 16-bit echograms it has always read.
• Added golden soundings button to profile window. They display in the survey window 

if Flags is checked.

• Improved echogram display.
• Improved smoothing.
• Better bin file detection with renamed files.
• Added Split Echograms button to Echogram window. This splits the echograms and 

displays the original echogram (depth 1) in the first window and depth 2 in a new window. 

Selecting Zoom Extents in an echogram window goes to the full extents of the echogram, 
sometimes far past the depth value recorded. The echogram windows draw raw depths, 
and the labeling of the graph has been updated to reflect that.

• The echogram windows draw raw depths, and the labeling of the graph has been 
updated to reflect that. Checking Show Raw Depths in the profile window will track the 
windows as-is, without any corrections to the scale of the echogram window. Unchecking 
Show Raw Depths in the profile window will track the corrected values, and applies a 
correction to the scale of the echogram window to move the raw depths into frame.

FILE OVERLAY

• Fixed Overlay dialog to work when HS2x survey files are loaded in SBMAX64.
• Added support for loading old ALL format files as overlays.
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SORT FEATURE

• Fixed SORT to properly mark matched files, fixing the sort function.
• Made the grid cells uneditable like SBMAX to prevent misuse of the dialog and bugs. 

Users must use the load button. 
• When using the up and down arrows to move cells, the window will scroll with the 

selection so that the selection is always on the screen.
• When a file that is being sorted does not have a match, it moves to the bottom of the 

spreadsheet to show it is unmatched, like SBMAX. Rows are renumbered as required.
• Backspace or Delete on keyboard deletes cells (because you can’t modify cell text 

directly.) 

64-BIT HYSWEEP® EDITOR (MBMAX64)
• Cross Hairs option in the Show area of the toolbar enables the point cursor in Stage 

1, and the cross hairs in Stage 2.
• Filter preview (Yellow X’s) draws faster. 
• Arrows on the track lines to show heading during logging.

Track Line Display

• Calibration window in Pop-up Cloud window: A new tool for LiDAR calibration is in 
MBMAX64 (64-bit HYSWEEP® EDITOR) uses cloud points instead of the cross section of 
our traditional patch test.  While there are advantages to each method, cloud calibration 
seems well suited to LiDAR systems.
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Figure 3:  Cloud Popup with Calibration Panel.

• Correct intermittent problems with sounding colors in the Sweep and Cloud 
windows.

• Corrected R2Sonic Water Column downsampling bug at 100m range.
• ROSS Multi-transducer data: If sound velocity = 0, MBMax64 replaces the 0 with 1500 

m/sec and reads the data instead of ignoring it.
• Reads sonar frequency from both RMB and SNR records, as drivers may log the data 

to either location.
• Saves WGS84 positions (when available) to the HS2x position datagram. Tested the 

GPS Recalc with HSX/HS2x files that contain WGS84 positions. (These positions can be 
omitted in HYSWEEP® SURVEY in the Logging Options dialog.)

• Correct File Date read error when loading S7K data.
• Exports 32-bit GeoTIFF of the matrix to Esri.
• Added an auto/manual check box for the heading graph. In manual mode, heading is 

always scaled 0 to 360 degrees. In automatic mode, heading is scaled to the data.
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• MBMAX64 now supports 7 frequencies. Previously only supported 4 frequencies.

SHOW OPTIONS

The most common options remain as check boxes in the toolbar. To access the rest, click 
[More...] and select additional options and a few new ones from the drop-down list.

Show Options

New options include the following:
• Direction Arrows draws survey direction arrows on 

the track lines. (Phase 1)
• Matrix Outline shows the border of the matrix. 

(Phase 2)
• SVP Casts tagged with location. (Phase 1) This 

option 
Sample SVP Cast)

> Sweep Window Data Border outlines the area shown in the Sweep Window. 
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Sweep Window Data Border

• Improved matrix display speed
• Export colors to HCF

• Reorientation of points in cloud popup from simple north up to arbitrary rotation.
• Updated Matrix class to support the "Last" option.  Added to selection list in main window.
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• Added Last option to matrix filters and save options.
• New show option = Channel Plan
• Added option to save to XYZ during auto processing. 

• Added option to save XYZ soundings while using the project’s rounding rules. 
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TPU EDITOR
• TPU graphs for the latest IHO 'Exclusive' Order

KONGSBERG ALL UPDATES

• Raw Data:
When loading RAW 78 datagram, we adjust the vertical offset in the Device Offsets 
dialog.  Offsets are found in ALL file Installation Parameters:
MBMAX64 Vertical Offset = S1Z – WLZ, where (according to Kongsberg documents) 
S1Z is Transducer 1 vertical location
WLZ is Water line vertical location.
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Raw Device Offsets

• XYZ Data:
> When loading XYZ-88 datagrams, all sonar offsets are set to zero in the Device 

Offsets dialog, as the soundings in XYZ-88 datagrams are already corrected for X, Y, 
Z, yaw, pitch and roll.

> Uses the combined draft/heave data from the XYZ-88 datagrams, so heave 
correction should also be set to 0.

> In the Patch Test, yaw, pitch and roll offsets are zeroed / ignored, as you can’t do 
patch testing using the XYZ data.

S7K UPDATES

• Loading S7K logged by PDS software displays a "This Version Can Not Read PDS 
Files". These datagrams cannot be supported in HYPACK® because the data is not 
sequential.
> Prevents program failure due to data grams (water column) that exceed the 

buffer size. In such cases, the program ignores the water column data.
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SIDE SCAN MERGE MOSAIC
Each file uses their own TFW coordinates rather than all of them using the same coordinates 
as the first file.

GEOCODER
Added support for the new snippets format written by HYSWEEP® (record number 7058).

MAGNETOMETER EDITOR
• Corrected error with Latitude and Longitude that were all logged at 0,0 (introduced 

after 21.0.4).
• Supports directly loading EXO Bin Files. All files must contain the same data 

combination logged in the same order in each record.
• Bug Fixes:

> Append to File Name option in the EDT save options resulted in empty LOG files.
> When you exported a series of XYZ files from the SORT routine, the autoname used 

the previous export value beginning with the second export.
> Corrected reading HDOP and Number of Satellites from i3XO data.
> Images of target area are included in the target record when exported from the WMA 

(Whole Magnetic Analysis) window.
> Depth Display no longer graphs anything when “None” is selected.
> When using a bad time filter, shore corrections will display an error in the lower right 

hand side instead of closing without notification. Shore messages are improved.
• Support for multi SMI lines.
• EC records are automatically loaded if no SMI records are available. If Record 

Device Specific Messages is unchecked in Hardware Setup for the magnetometer, a pop 
up alert will notify you in case this wasn’t intended so you can update your hardware 
settings for future surveys.

NEW PROGRAM: ENVIRONMENTAL EDITOR
The ENVIRONMENTAL EDITOR provides the tools to process your environmental data 
stored to SMI records:
• Clean bad data using point and block editing tools, and the Search and Filter options.
• Generate contour maps of each value.
• Generate reduced XYZ files for plotting.
The ENVIRONMENTAL EDITOR recognizes SMI records, and makes them available for 
viewing and manual editing in the Profile and Spreadsheet windows. 
When you load raw data with SMI records, the program opens the Special Marine Instrument 
(SMI) dialog with a listing of available values. These options vary according to the device you 
are using and what you are recording. You can configure each window to display up to 32 
such values in a single editing session. The Profile window graphs each value using a 
different color.
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Sample Special Marine Instrument Dialog

Cleaning your Data
• In the Survey window, you can only edit the track lines (positions), though the display 

shows the value selected in the toolbar. When position data is removed, the 
environmental data is deleted or interpolated based on the status of the delete option on 
the toolbar—Delete Removes Position vs Delete Interpolates Position. If start or end line 
positions are deleted, all positions are deleted as no interpolation can occur.

• In the Profile window, select one or more value to display using the list in the panel. 
Manual editing tools affect only the values you select, and filters affect only the Basis 
values selected in the Search and Filters dialog.

• In the Spreadsheet, you can manually edit the values in individual cells or fill a column 
with a uniform value.

Mark Targets
Select the point where the target should be 
placed and click the Quick Target icon (F5). A 
Target dialog appears with the XYZ coordinates 
of your selected position and the default name 
(time) and target group (ENVIROEDIT).

Saving Edited Data
When you have finished editing your data, save 
your edited data to a HYPACK® Session file, 
HYPACK® ALL or XYZ format, or use the Sort 
or Contour routines to generate sorted XYZ or 
DXF contour charts of a select value. 
• Session files (*.SMI) can restore your data 

in its current state without re-editing
The other file types are useful in other 
HYPACK® modules to display your data and 
generate final products such as plotting sheets, cross section profiles, and surface models.
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• All format options enable you to customize the filenames and extensions.
Tip: You can customize the file name to show the output Z value in each dataset.
• XYZ format output stores the user-defined value at each XY position.

Save Options Dialogs—All Format (left) XYZ (right)

• Sorted XYZ. The SORT routine thins data while it guarantees the minimum data value at 
their proper locations.

• DXF charts of targets or data from environmental studies.The output files can be used as 
a HYPACK® chart or imported to third-party CAD programs.x

• Added a dialog to TIN data (ie: Temperature) and create a colorized profile using 
data from a vertically undulating i3XO profiler. This is only available in the 
Environmental Editor. To open, go to Processing > Environmental Editor, then in the 
Environmental Editor window click Tools > Undulating Sensor Display.
> You need to select the Depth Channel and Sensor Channel from the drop downs. 
> [Refresh] reloads the depth information
> [Run] TINs the sensor data. From that point you can see your data. It may help to 

disable the depth or grid lines. 
> Use the scroll wheel over the chart to zoom in/out. 
> Left click and drag will pan, and right click and drag is zoom window. 
> The scale colors icon on the upper right scales the color bar to the min/max values of 

the sensor's data.
> The camera icon on the upper right saves the chart as a JPEG.
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Undulating Sensor Display Showing Depth and TIN’d Temperature

SUB-BOTTOM PROCESSOR
Works in survey units rather than meters only.

FINAL PRODUCTS

HYPLOT
• Fixed the tree view check boxes.
• Right-click on the color bar and select Settings accesses the Color Manager.
• SHOM title box prints in its entirety.

NEW PROGRAM: HYPLOT MAX
In the HYPACK 2022 install, HYPLOT MAX replaces HYPLOT Multi. HYPLOT MAX comes 
with several improvements:
• Easily view and define item properties in the main window
• *.plt files are no longer required to start up HYPLOT MAX
• Multiple maps and *.plt files can be plotted to one sheet

Finished plot layouts can be exported as a PDF or TIF file, or printed using a Windows®-
based printer. Note that layout files are now saved as HYPLOT Project (*.hpr) files instead of 
Layout (*.lot) files.
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HYPLOT MAX Interface

Creating a Sheet
A sheet is where you add multiple plot items like map areas, symbols, and title blocks. 
Resize the sheet by right clicking on it and selecting from the standard predefined sizes.
Add map areas to the sheet by clicking Map Area > New Map Area or select one of the *.plt 
files from the list. You can drag the map area and resize it, and edit displayed project files 
from the Charts section. You can also add map items like color bars, scale bars, and 
compasses, which provide context to your map area, from the Map Items menu.
Images, shapes, arrows, text boxes, and time stamps can also be added from the Plot Items 
menu.
Item settings can be viewed and changed by clicking on the item’s name in the Items tree 
view, then updating the value from the Properties section.

Title Blocks
HYPLOT MAX has multiple predefined title blocks that you can choose from and edit, or you 
can create your own title block and add it to your sheet.
To insert a predefined title block, click Add > Block and select one of the default *.htb block 
files listed. Modify the text in the title block by right clicking on it and typing in the Text 
Property Editor. Move the title block by holding SHIFT while clicking and dragging the block.
To create and add a custom title block, first open the Title Block Editor by clicking View > 
Block Editor. In the Block Editor, add any images, shapes, and text, then click File > Save to 
save the custom title block *.htb file. Insert the newly created block on your sheet by clicking 
Add > Block > Browse, and select the *.htb file you saved.

Print and Export

Print your finished plot layout with a Windows®-based printer by clicking File > Print. 
Select your plot mode and resolution, click [OK], then click your printing device.
You can also export your plot layout as a PDF or TIFF. Do this by going to File > Export > 
PDF or TIFF. Select the appropriate format and resolution for your output file, then click 
Output or OK.
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TIN MODEL
• New Volume Report Options:

> Extended choice of Volume Report file formats: In addition to the text file formats 
we’ve been using for years, you can also save your volume reports to PDF, Comma 
Separated Values (*.CSV), or to an Excel File (*.XLS). 

> Append or Overwrite: When you export to CSV, XLS or PDF format, you must name 
your output file. If you select the name of an existing file, you can append the new 
report to the existing file (of the same format), or overwrite it. When you append the 
report to an Excel spreadsheet, the new report appears on a new sheet in the same 
file. 

Tip: You can even append your PDF volume report to a PDF exported from HYPLOT to 
keep both reports in one document.

> Landscape or Portrait Orientation: When you export to PDF format, choose the 
paper orientation that best fits your data. When you have several columns or your 
language makes longer labels, Landscape orientation helps prevent column labels 
from overlapping. 

> Show Report When Done opens your report in the appropriate application when the 
export is complete,

• Improved 2D drawing: 
> Speeds are increased 
> 2D fill and contour charts now included with other chart files.

• Supports contours at cm resolution. 
• Improvements to custom resolutions.
• Corrected drawing when Show Picture option is selected. (The drawing in the preview 

and output file were always correct.)
• Fixed bug in DXF Export: With an XYZ file as a background file in EDIT-TIN menu then try 

to export contours in DXF, no DXF is exported.

UTILITIES

ADCP PROFILE
ADCP Profile Information Window

• More extensive Information 
display: Added Ensemble Depth, 
Bin Size, Max Bin/Ensemble, 
Distance to First Bin. Bin Depth 
and Final Bin Depth.

• Corrected off-screen dialog 
problem.
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MANUAL TIDES

• Corrected problem reading NOAA tides on Windows® 7 computers.

CROSS SECTIONS AND VOLUMES
From the Print tab, you can export images of one or more pages configured according to your 
print parameters. In the Print Tab, when “Sheets Per Page” is set to “Multiple”, the dimension 
of the image is set based on the paper size selected in the FILE-PRINT SETUP to maintain 
best quality and prevent loss of data. 
The program stores the images, by default, to the project \Edit\CS&V Images folder, but you 
can click [Browse] and choose a different folder.

Export Dialog

Sample Output

EXPORT TO CAD
• Corrected export of planned lines with arcs.

ENC EDITOR
• Changed S57 Read and Write routines to handle Ansi, Latin-1 and UCS-2 encodings. 

These are the 3 lexical levels described in the standard.
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TARGETING AND MOSAICKING
• Loads Klein 5900
• Corrected loading of JSF files where the speed in the spreadsheet view appears 100 

times too high, and that depth isn't appearing in one of his datasets.

CLOUD
• Toggle off axis and perimeter display

MERGE XYZ
• Changed “Negate Z Value” to “Invert Z Value (XYZ)”. Z values of the XYZ file are inverted.
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SOUND VELOCITY
• Added support for AML-3 Orange Line Probe.

DOCUMENTATION UPDATE

We discovered that the HYSWEEP® and Side Scan Interfacing Notes were missing some 
supported devices. We’ve added these devices and included these updated documents with 
the other file updates.
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